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1. Installing AsterDTM 
 
 
This section describes the installation of the AsterDTM module.  
 
Once you receive the AsterDTM module (either as an email attachment, or through download 
from a customer area on our web page) you should save it to your RSI directory ( or a directory 
where you keep  install routines). Impor tant note: Do not put the install_asterdtm.sav file into 
your SAVE_ADD directory. 
 
In ENVI, activities/functions/routines are initiated by using the ENVI main menu. The 
AsterDTM installation procedure let’s you interactively select where to put the new menu entry 
for initiating the AsterDTM routine, and copies the necessary .sav file to the SAVE_ADD 
directory in you ENVI installation.  After having successfully finished the installation, you may 
execute install_asterdtm.sav again at any time, to either uninstall AsterDTM from your ENVI 
installation, add an additional menu entry, or update the asterdtm.sav file .  
 
 
 
- STEP 1: Executing install_asterdtm_* 
 
 
For Window : 
 

Double click on the install_asterdtm_*.sav file (with *  being a string representing your 
individual installation file) 

 
 
For Linux / UNIX : 
 

Open a shell in your console, and type – 
 
 

% idl_6.1 -rt=directory/install_asterdtm_*.sav 
 
 
with "directory" being the directory where asterdtm.sav resides. 
 
 
A dialog box will pop up with the license agreement. To proceed with the installation, you have 
to click on the “Accept”  button to accept the agreement. If you click on “Decline”  or dismiss the 
window, the installation will finish here. 
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After scanning your system for the appropriate ENVI configuration file, the following dialog 
box will pop up:  

 
 
 
For most installations the automatically defined file path should be correct. If for any reason this 
path has to be edited, then the file path can be modified by clicking with the left button in the 
text field, and navigating in the ENVI default file selection dialog window to the correct ENVI 
4.1 configuration file. Click "next->" to continue. 
 
 



Installation & User’s Guide                                                                                    

 

6

6 

Before the next step, the current ENVI menu file is being scanned for any occurrence of a 
 
previous installation of AsterDTM. Please refer to “Uninstall/Modify the AsterDTM 
installation”  on page 6  for the options available for uninstalling, modifying or updating an 
existing AsterDTM installation. 
 
 
- STEP 2: Defining a new menu entry 
 
Choose one of the options below: 
 

 
 

� � Include new menu entry as ENVI main menu item 
 
This option will allow you to define a new main menu entry like in the example below. Passing 
the mouse cursor over the main menu will change the position within the main menu. Click on 
the new AsterDTM button whenever you©re done. 
 

 
 
 
 

� � Include new menu entry as ENVI submenu item 
 
This option allows you to click on a particular main menu entry (for instance "Map"), and 
define the position of the new menu entry my passing the cursor over the sub menu entries, 
which will change the position of the entry in the sub menu . Click on the new AsterDTM 
button whenever you©re done. 
 
 
At any time, for either one of the two options, you may edit the name for the new menu entry by 
editing the text field below “Define new menu entry string” . 
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- STEP 3 Finishing the Installation 
 
Click "next" to move on to the final installation step. 

 
 

 
 
The final install screen may vary depending on whether you executed a new install, or whether 
you just updated/removed menu entries and/or the binary asterdtm .sav file. Click on finish to 
execute the modifications listed on the screen, or on "<-prev" to return to the previous steps. 
You have to restart ENVI / ENVI RT in order for the recent changes to take effect.  
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Unistall/Modify the AsterDTM installation 
 
If you already have a valid entry for AsterDTM in your current ENVI main menu file, the 
following dialog box will pop up: 

 

 
 
Please choose among the four options offered: 
 
Only update .sav file - no changes to menu : 
 
This option is to only update the current version of the asterdtm save file, without changing the 
menu structure of your ENVI main menu file (you already have a valid entry for AsterDTM if 
you got to this options screen). After clicking "next->" a confirmation will prompt you for 
confirming the desired action, and execute it . 
 
Add additional menu entry and update .sav file : 
 
This option will allow you to update the current version of AsterDTM (if there is a new 
version), and in addition put a new menu entry elsewhere in you ENVI main menu or one of the 
sub menus. Selecting this option and clicking "next->" will take you to the "step 2" screen. 
 
Remove all menu entr ies- no changes to  .sav file : 
 
This option will remove existing entries for calling the AsterDTM module from your main 
menu file, but leave the binary in the save_add directory.  After clicking "next->" a 
confirmation will prompt you for confirming the desired action, and execute it . 
 
Remove all menu entr ies and remove  .sav file : 
 
This option will remove existing entries for calling the AsterDTM module from your main 
menu file, and remove the binary from the save_add directory.  After clicking "next->" a 
confirmation will prompt you for confirming the desired action, and execute it . 
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2. AsterDTM Operation 
 
Introduction 
 
AsterDTM is an ENVI plug-in for extracting digital elevation values from ASTER 1A and 1B 
images. Please refer to chapter 2 “ Installing AsterDTM” for instructions on how to install 
AsterDTM. 
 
The ASTER (Advanced Spaceborne Thermal Emission and Reflection Radiometer) sensor is a 
cooperative effort between NASA and Japan©s Ministry of Economy, Trade and Industry 
(METI) and the Earth Remote Sensing Data Analysis Center (ERSDAC). Flying on the TERRA 
platform, a satellite launched in December 1999 as part of NASA©s Earth Observing System 
(http://ASTERweb.jpl.nasa.gov/), ASTER covers a wide spectral region with 14 bands from the 
visible to the thermal infrared with high spatial, spectral and radiometric resolution. The spatial 
resolution varies with wavelength: 15 m in the visible and near infrared (VNIR - 0.55 to 
0.80um), 30 m in the short wave infrared (SWIR - 1.65 to 2.4um), and 90 m in the thermal 
infrared (TIR - 8.3 to 11.32um). An additional band (named 3B, for “backwards”) works at the 
same spatial resolution as the ordinary band 3 (named 3N, for “nadir” ) of the VNIR sensor, but 
at a backward angle of approximately 28 degrees, producing a stereo pair for each ASTER 
image. 
 
The basic principle behind the DTM extraction with AsterDTM is the well known parallax 
effect - you look at an object from two different angles and thus can obtain it©s third dimension. 
Each ASTER image contains it©s own stereo pair - looking at the same terrain from two different 
angles, provided in the form of a 3N / 3B stereo pair with 15 m spatial resolution. AsterDTM 
converts these two bands into a pair of quasi-epipolar images, which have a pixel displacement 
in the satellite flight direction proportional to the pixel elevation. A cross-correlation method is 
used to determine this displacement, which in turns is transformed into elevation values. 
 
 
Getting Started 

 
                                           Fig.1: AsterDTM start center 
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To start AsterDTM, navigate within the ENVI main menu to the menu entry for the AsterDTM 
module and click on it. The AsterDTM command center pops up, with initially most processing 
options grayed out.  
 
These options will be made available as the processing of your ASTER image proceeds. The 
status line on the bottom of the command center describes the current action, or the processing 
step to follow. 
 
As of AsterDTM version 2.0, a short cut menu is available with a subset of the processing 
options, accessible by clicking with the right mouse button anywhere in the background of the 
AsterDTM start window: 
 
 

 
 
 
Please see the chapter “Options menu -> Defining processing options”  for a detailed description 
of theses processing options. 
 
The command center has two pulldown menus, “File”  and “Options” .  Click on “File  -> Open 
ASTER HDF file (1A or 1B)” , or click on the “Aster Input File:”  button to open an ASTER 
HDF 1A or 1B file through the standard ENVI file selection dialog (fig. 2). If the ASTER file 
you want to process is already open then you can directly select it from the list, otherwise click 
in “Open File…” to open the file selection window and navigate to the file you want to open 
(Observation: the usual option to spatially subset the image “Spatial Subset”  is not made 
available here because the subsetting is being done in a later stage). 
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                                        Fig. 2: File selection dialog windows 

 
When you open an ASTER file in HDF format in ENVI, then this file is split up into its image 
data sets, depending whether it’ s level 1A or 1B. The ASTER 1A HDF files are composed of 
six image files: the three VNIR (15 m) bands separated (Band1, Band2 and Band3N), the 
backwards 3B band (band3B), the six SWIR bands together, and the five TIR bands together.  
The ASTER 1B HDF files are composed of 4 image files: the three VNIR bands together, the 
backwards 3B band (band3B), the six SWIR bands together, and the five TIR bands together.  
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You may select any of these data sets, as AsterDTM automatically identifies the VNIR 
components.  If the file is not a valid ASTER 1A or 1B HDF file, an error message is displayed. 
 
After having selected the ASTER input file, a status window  “Reading ASTER data sets…” 
pops up, and the image files, geometric and radiometric calibration data and all other necessary 
information are extracted from your ASTER file. The subsequent processing steps depend on 
whether the selected image is of type level 1A or level 1B. 
 
 
ASTER 1A->1B correction 
 
VNIR:  
 
The level 1A VNIR bands (including band 3B) have to be corrected radiometrically and 
geometrically in order to be able to extract elevation values through parallax evaluation. As a 
first step, the user is prompted for an output filename for the 1A-1B  VNIR  corrected file: 
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A suggested output file name is automatically constructed from the input ASTER file name. It 
can be edited directly, or the “choose”  button can be used to navigate to the desired output 
directory and file name. 
 
If the corrected ASTER 1A->1B VNIR file for this particular ASTER image has already been 
produced before, the latter file dialog will be replaced by the one below. In case the selected file 
name points to an already existing file, then this file is being examined internally in order to 
determine whether it is the valid result of a previous 1A->1B conversion; if this is the case, the 
following dialog window pops up:  
 

 
 
The first option, “Use already existing file” , opens the selected file read only and jumps directly 
to the warping of band 3B, and the second option overwrites the already existing file. The third 
option “Select a different output file name below”  is effectively there only to complete the list 
of options, and is executed through selecting a new file name with the “choose”  button. 
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In case the selected file name already exists but is not identified as the corresponding 1A->1B 
file, the user is prompted whether he really wants to overwrite this file. 
 
The processing of the ASTER 1A bands goes through the steps of replacing bad lines, applying 
radiometric calibration coefficients in order to remove banding and striping effects, removing 
any remaining high frequency noise from the 3N band, geometrically correcting bands 1,2 and 
3N, and finally co-registering these bands with respect to each other. The same processing is 
then applied to the 3B band, creating a temporary file in the temporary directory defined by the 
ENVI users preference “Default Temp Directory” . 
 
 
SWIR / TIR  :   
 
ASTER 1A SWIR and TIR bands can be corrected geometrically and radiometrically through 
the options  
 
“File”  -> Create 1A->1B SWIR equivalent”        and 
“File”  -> Create 1A->1B TIR equivalent”     
 
in the start center  File menu   .  The dialog window is similar for the SWIR and TIR bands 
(except that for TIR the filter option is not available, because there is no need for filtering), and 
is shown below for the “File”  -> Create 1A->1B SWIR equivalent”  case: 
 

 
  
 
The user has the option to select whether or not filtering (FFT filter) and/or radiometric 
correction is to applied, and whether the output is to memory or to a disk file. In case the disk 
file already exists and carries the specifics of the SWIR 1A_>1B corrected file, the user is 
prompted to either use this existing one, overwrite it, or choose a new output filename, very 
much like in the VNIR radiometric and geometric correction.   
 
Geometric correction of SWIR and TIR 1A bands is achieved by automatic identification of tie 
points between the SWIR/TIR bands and VNIR band 3N, on a band-by-band basis , and 
subsequent registering. The success of this operation depends on the quality of the image (low 
cloud coverage) and sufficient areas of high correlation. It is recommended to check the quality 
of the inter-band registration for each instrument, prior to further processing of these results. 
 
Once the operation has been completed, a check mark appears at the corresponding menu entry 
to signal the execution of this task. 
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Defining DTM output file name and Spatial Subset 
 
Having selected an ASTER 1B file, or at the end of the pre-processing of an ASTER 1A file, the 
user is prompted to define the spatial subset for the processing, and the output file name for the 
DTM to be extracted: 
 

 
 
The “Output Result to”  option lets you choose between saving the resulting DTM to the file 
defined under “Enter Output Filename”, or to system memory. The button “Spatial Subset”  
opens the ENVI standard dialog window for spatial sub setting. Please see “Options Menu: 
Defining Processing Parameters”  for the option to output the resulting DTM north oriented, 
instead of the default orbit oriented. 
 
 
Using Ground Control Points (optional) 
 
One of the strengths of the AsterDTM module is the capability to extract and use the ground 
control points provided by the ASTER image itself, stored in the ephemeris part of the HDF file. 
The precision of these internal GCP’s is extraordinarily high, allowing the geopositioning of the 
orthocorrected bands with an x/y error of less then 50 m, without the need of any external 
ground control points (GCP’s). 
 
However, AsterDTM -  starting from version 2.0 – provides the option to import and collect 
GCP’s in order to  either improve the georeferencing from ephemeris data and/or  calibrate the 
elevation values to turn the relative output DTM into an absolute one. GCP’s can be entered 
either in the form of a pre-existing GCP points file (ENVI default * .pts, through the “GCP Input 
file:”  button), or by starting the collection of GCP’s through the “collect GCP’s”  button in the 
start window.  
 
GCP Input File:  Use this option to load a GCP file resulting from the previous collection of 
ground control points in ENVI  (either directly, or within the AsterDTM module). There are two 
types of files which can be imported: 
 

·  The GCP file produced through the “File->Save GCPs w/ map cords …” option 
in the Ground Control Points Collection windows 

·  The GCP list (table) produced through the “File->Save table to ASCII …” 
option in the Ground Control Points List window (you open this window in the 
Ground Control Point Collection window by clicking on “Show List” ) 
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Either of these files can be the result of  a previous GCP collection from within AsterDTM , or 
from a GCP collection within standard ENVI. The main difference between the two files is that 
the GCP file contains all collected points, not indicating which files are “On”  and which are  
“Off” , whereas the GCP list indicates which points have currently been disabled for processing 
by the user (please see the standard ENVI documentation Map Tools->Rectification and Map 
Tools->Orthorectification for a detailed description of the GCP collection window and it’ s 
processing options). 

 

Collect GCP’s:   Use this option to interactively collect ground control points from within the 
AsterDTM module. Selecting this option will automatically open a new display window with 
the ASTER 3N band displayed (grey scale), and the standard ENVI Ground Control Points 
Collection window (with the option of entering elevation values).  

 

 

GCP’s are being collected by clicking on the selected location either in the image window or in 
the zoom window (recommended), typing in the corresponding elevation value (in meters), and 
the geographic coordinates. Please mind that the map projection is automatically set to the 
projection of the input ASTER image, and must not be modified. Geographic coordinated may 
be imported from other images or vectors, regardless of their map projection, and will be 
converted on the fly by ENVI (f.i. open the georeferenced base image in another display, open 
the pixel locator with “ tools->pixel locator” , in the pixel locator window click on “options-> 
Map coordinates” , left-click on the desired position in the base image (in the zoom window), 
and click on the Export”  button – the coordinates will be converted on the fly and inserted in the 
East and North fields of your Ground Control Points Collection window (for vectors there is a 
similar mechanism – open the vector in a new vector window, right-click in the vector window 
and use “Export Map Location”).  Add new newly collected point by clicking on the “Add 
Point”  button in the GCP collection window. 

There are three kinds of control points you may define: 

1. XYZ GCP’s: all available information (x, y coordinates and elevation ) is provided 
by the user. These points will be used for both georeferencing the output images 
and calibrating the output DTM. 

2. Horizontal tie points: If you have the x and y coordinates for a specific point but 
the elevation at this location is unknow, you may use this point as a horizontal tie 
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point (it will be used for the georeferencing process, but not for the calibration of 
the output DTM). Please enter –999 (or less) in the elevation field to indicate that 
this is a horizontal tie point. 

3. Vertical tie points: If you now the elevation at a certain location, but not the map 
coordinates, you may use this point as a vertical tie point (it will be used for 
calibrating the output DTM, but not for the georeferencing process). This is 
particularly useful if you want to fix a  location to a certain elevation value . Please 
enter 0 (zero) in the E and N fields of the map projection information to indicate 
that this is a vertical tie point.    

There are a lot of options which allow you to handle and manage GCP’s more efficiently – 
please see the standard ENVI documentation Map Tools->Rectification and Map Tools-
>Orthorectification for a detailed description of the GCP collection window. 

Please mind that the geometric correction and the shape of the  extracted DTM continues to be 
determined by the ephemeris parameters of the ASTER HDF image; ground control points and 
vertical tie points are used to move the output DTM to the correct geolocation in XYZ space by 
means of a 3-D rubber sheeting. Therefore theoretically the minimum number of GCP’s is one; 
either for determining the x/y offset, and/or to define the height offset between the absolute 
elevation values entered by the user, and the elevations determined by the AsterDTM module. 
However, whereas for the horizontal rubber sheeting one well defined  GCP is enough, we  
recommend using at least four or five well distributed control points, in order to determine the 
height offset. Please also remember that this is a case where the RMS error displayed in the 
Ground Control Point Collection window is not a good measure for the quality of your ground 
control points, as you are setting the points in an image which is yet to be orthocorrected. This 
orthocorrecton may imply shifts of up to several hundred meters, depending on the absolute 
elevation and the pointing angle of the instrument.  

Once you finished collecting your GCP’s, before transferring them to the AsterDTM module, 
you should save them to a file either by using the File->Save GCPs w/ map coord …” option in 
the GCP collection window, or through showing the list of GCPs with “Show List”  and saving 
this list through the “File-> Save  Table to ASCII”  option in the GCP List window  .   

The newly collected GCP’s have to be transferred to the AsterDTM module by means of the 
“Export points to AsterDTM” entry in the options menu of the GCP collection window: 

 

Please mind that this will transfer all collected points, regardless whether they are switched on 
or off in the GCP list window. 
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The GCP information will be silently used to improve the georeferencing of the output images, 
and to calibrate the output DTM. You may check the effect of your input GCP’s by disabling 
the use of the GCP’s , by checking off the “Use GCP’s”  button (either right-click in the start 
center window, or choose “Options->Define processing parameters” ->Processing and check off 
“use GCP’s box).  
 
Starting the ASTER DTM extraction 
 
Once the DTM output file and the spatial subset have been defined, the start center shows the 
file definitions, the “Change spatial subset”  button and the “Start ASTER DTM extraction 
buttons are active, and the currently selected spatial subset and the approximate time to extract 
the DTM for this subset are shown.   
 
 

 
 
The “DTM Output File”  and the “Change spatial subset”  buttons provide the same functionality 
of defining the output file name and the spatial subset. 
Clicking on “Start ASTER DTM Extraction”  starts the process of iteratively extracting and 
refining the digital elevation model for the selected spatial subset. 
 
The extraction of the DTM requires four correlations scans plus post processing, and  takes 
about the time indicated in “Estimated processing time:” , estimated on the basis of a single 
processor/single user configuration. Once the process is finished, the resulting DTM and the 
corresponding correlation score map (see “Analyzing the correlation score map”  for details) 
show up in ENVI’s Available bands list (ABL), and the “Apply orthocorrection”  button turns 
active. 
 
 
Applying Orthocorrection 
 
Once the DTM extraction process has finished, the produced elevation model can be used to 
correct the ASTER 1B bands or the ASTER 1A->1B corrected bands, for displacement errors 
caused by the parallax effect, particularly useful in mountainous regions and for ASTER images 
with a non-zero pointing angle (instrument looking aside). The procedure is slightly different for 
ASTER 1A and 1B images. 
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Clicking on the “Apply orthocorrection”  button opens a dialog window similar to the one 
below. (for ASTER 1A images, if neither for SWIR nor for TIR the geometric and radiometric 
correction has been executed, this dialog window is being skipped) : 
 

 
 
After selecting the desired subsystem files (one at a time) , the following dialog window 
appears, 
 

 
 
allowing the definition of the spatial subset and the output file name for the orthocorrected file, 
as well as an option for defining the output file geographic orientation (orbit oriented, or north 
oriented). For ASTER 1B images only, there is also an option for calibrating the output DN 
values to radiance, using the conversion coefficients in the ASTER 1B HDF file (for ASTER 
1A images, the calibration – if so desired – has to be executed together with the geometric 
correction).   The spatial subset is effectively limited to the area of overlap between the image 
and the DTM, and may only be smaller but not larger then the subset initially indicated.  
 
The result of the orthocorrection is accessible through the Available Bands List. 
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Batch File Setup 
 
Aster 1A or 1B images in general do not need any user input and can be processed 
automatically in batch mode through the ASTERDTM_DOIT routine. As of AsterDTM 
version 2.2, a new facility has been provided which allows the interactive setup for 
automatic processing of as many images as desired. The batch file setup can be 
initialized through the File->Batch file setup menu option: 
 

 
 
Batch file setup can be invoked right after the start up of AsterDTM, without the need to 
open any Aster images beforehand. Setup for batch execution is done through the Batch 
Mode Setup Window: 
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The objective of the Batch Mode Setup Window is to allow the user to select a couple 
of  ASTER images and define a set  processing parameters to be applied automatically 
to each one of these files. Images can be selected in three ways: 
 

 
  Add Files                : Select files/images one-by-one (multiple Shift/Ctrl   
                                      selection supported)  
 
  Add Directory          : Select a directory to be scanned for valid Aster 1A/1B  
                                      images 
 
  Add Directory Tree: Selected a directory to be scanned recursively (all sub-     
                                      directories) for valid Aster 1A/1B images (may be time  
                                      consuming, depending on the directory structure/depth) 
 
 
Files can be added to the “List of Files”  window through any of these three options. 
Undesired files can be removed by selecting them in the “List of files”  window and then 
clicking on the “ remove selected files”  button. 
 
Output file names for the extracted DEM and selected products (like VNIR orthoimage) 
are derived automatically from the input file name(s), and stored in one output directory 
(even though the input files may reside in different directories/drives). The output 
directory has to be defined by the user prior to starting batch operation: 
 
 
   Define output directory : Select directory where to store selected output files 
 
As soon as the mosaic file have been created , the spatial subset option is being made 
available: 
 

Spatial Subset Full Range : Click to modify the spatial subset for the  
               resulting DEM/output files 

 
 
 
Optional: 
 
   Create Correlation Images 
   Create 1B equivalent (1A only) 
   Create VNIR Orthoimage 
   Create SWIR Orthoimage 
   Create TIR Orthoimage 
   Convert to radiance 
   Apply FFT filter 
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Select any of these options (non-exclusive) to create the corresponding output file; f.i.,  
“Create VNIR Orthoimage” will create the orthocorrected image for the three VNIR 
bands.  
 
Other processing options can be defined through the “Define Processing Options”  
button: 
 
 
   Define Processing Options : Equivalent to  

   “Options-> Define Processing Parameters”  
(Obs.:One (the) set of selected processing parameters apply to all images in the “List of 
files”  window) 
 
 
After having selected the input files, the output directory, output files and processing 
options, the processing of all files in the “List of files”  window can be started through 
the   “execute”  button: 
 
   Execute  : Start batch processing 
 
Progress of the batch processing is being listed in the output log window (below the List 
of Files window)., and may be saved to a file through the “save log to file”  button. 
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Mosaic Setup 
 
Starting with AsterDTM version 2.2, a new facility has been  provided which allows the 
mosaicing of Aster 1A/1B images The mosaic setup is initialized through the  
File->Mosaic setup menu option: 
 

 
 
Mosaic setup can be invoked right after the start up of AsterDTM, without the need to 
open any Aster images beforehand. Setup for mosaic execution is done through the 
Mosaic Setup Window: 
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The objective of the Mosaic Setup Window is to allow the user to select a couple of  
ASTER images, define a set  processing parameters and mosaic the images 
automatically.  Images can be selected in three ways: 
 

 
  Add Files                : Select files/images one-by-one (multiple Shift/Ctrl   
                                      selection supported)  
 
  Add Directory          : Select a directory to be scanned for valid Aster 1A/1B  
                                      images 
 
  Add Directory Tree: Selected a directory to be scanned recursively (all sub-     
                                      directories) for valid Aster 1A/1B images (may be time  
                                      consuming, depending on the directory structure/depth) 
 
 
Files can be added to the “List of Files”  window through any of these three options. 
Undesired files can be removed by selecting them in the “List of files”  window and then 
clicking on the “ remove selected files”  button. 
 
Important notes :  The main criterion for acceptable results is the pointing angle – it 

shouldn’ t vary more than at most +- 1 degree for the images 
participating in the mosaic, otherwise the quality  of the output 
DEM will be compromised.   
It is possible to “mix”  ASTER 1A and 1B images if necessary, 
but preferably mosaics should be composed of either 1A or 1B. 
RAM memory usage (and processing time) is proportional to the 
number of participating scenes, therefore it is recommended not 
to mosaic more than 3-4 scenes in one go. 
  

 
Please use the  
 
   Define output file name : Define DEM output file name 
 
option to define the output file name for the extracted DEM; the output file name for the 
corresponding correlation file is derived automatically from the DEM output file name. 
 
Prior to executing the DEM extraction, the participating ASTER images have to be 
mosaiced (one mosaic for all 3N bands, another one for all 3B bands): 
 
   Mosaic input files : Create 3N and 3B mosaic files 
 
The mosaicing results for 3N and 3B bands is shown in the available bands list – it is 
recommended to inspects these files for consistency prior to executing the DEM 
extraction.  As soon as the mosaic file have been created , the spatial subset option is 
being made available: 
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Spatial Subset Full Range : Click to modify the spatial subset for the  
               resulting DEM 

 
 
At any time, processing options for the DEM  extraction – very much like for a single 
Aster file – may be  defined through the “Define processing Options”  button: 
 
  
 
   Define Processing Options : Equivalent to   
                                                              “Options-> Define  Processing Parameters”   
 
 
 
After having selected the input files, the output file name, mosaiced the input files, 
eventually selected a different subset and processing options, the DEM extraction can 
started through the   “Start DEM Extraction ”  button: 
 
   Start DEM Extraction  : Start processing 
 
In order to abort an ongoing DEM extraction, please use the “cancel”  button on the 
ENVI status  window. Use the  “Quit”  button on the Mosaic Setup Window to quit the 
mosaic routine: 
 
   Quit     : Dismiss Mosaic Setup Window 
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OPTIONS MENU 
 
Options menu: Display ASTER File header info 
 
This options displays information extracted from the ASTER HDF data entries: 
 
 

 
 
 
Options menu: Defining processing options  
 
There are several processing and output options the user can change through the “Options -> 
Define Processing Parameters”  menu entry in the AsterDTM start center. The processing 
parameters window is divided in four sections, each one accessible through clicking on the tab 
title: 
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DEM min/max value: Minimum and maximum elevation values to be 

encountered in the selected spatial subset; this is mere 
hint to the AsterDTM module to quickly establish the 
possible range of elevations. In general there is no need 
to modify the default values, unless very high 
elevations  ( > 6000 m) are to be expected. 

 
DEM constant offset: The extracted DTM is a relative one; this option allows 

applying an offset to all elevation values (positive or 
negative), either prior to starting the DTM extraction, 
or after having finished processing. In the latter case 
the user is being asked whether he wants to apply the 
offset immediately. 

 In case of using an external DEM or user defined 
GCP’s on finishing the DTM extraction this field will 
show the effective offset between the external elevation 
values and the AsterDTM output DTM. 

 
DEM output pixel size: The output DTM pixel size in meters. Available pixel 

sizes are 60m / 30m / 15m .  A smaller pixel size takes 
longer to process (about 3 times), and vice-versa. 
Impor tant: elevation values are always extracted at 
the highest possible resolution (15 m), no matter what 
the setting of the output DEM pixel size is. 

   
Output DTM north oriented Click on the check box to have the output DTM and 

the correlation image rotated to be north oriented. The 
default for these images is to be orbit oriented , which 
results in a rotation angle (relative to the map grid) of 
around –10 degrees. Choosing this option is 
particularly useful when you want to mosaic the output 
DTM’s. Please mind that you can use at any time Basic 
Tools->Rotate/Flip Data from within the standard main 
ENVI menu to rotate the orbit oriented output images. 
If this option is chosen, then north orientation of the 
orthocorrected images is also the default. 

     
 
DEM Nodata value: The numerical value that AsterDTM assigns for 

regions where no elevation value could be extracted 
(f.i. because of lack of image data) 
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Interpolation Method: The default method for interpolating the correlation 

values for each image subset is an optimized cubic 
interpolation along the orbit direction (1-D cubic). A 
slightly better vertical precision (~5 % improvement) 
may be achieved by using the 2-D cubic interpolation, 
although at the price of a significantly enhanced 
processing time. 

 
Correlation matrix size: In order to identify  -  on a pixel-per-pixel basis – the 

correct offset between the nadir band and the back-
looking band, it is necessary to compare image chips of 
a reasonable size – large enough to allow unambiguous 
identification, but small enough to resolve the 
morphologic structures (very much like a kernel for 
convolute filtering). The default setting is for a 9x9 
matrix ; smaller settings result in finer spatial (x/y/z) 
resolution, but are more susceptible to false 
correlations, whereas larger values are more robust at a 
lower resolution.  

 
Use water detection: The DTM extraction in AsterDTM is fundamentally 

based on the correlation between the nadir image  and 
the back-looking image; water, due to it’ s 
homogeneous appearance, is almost impossible to use 
for a correlation analysis, rendering very low 
correlation values and therefore very noisy, unreal 
elevation values. AsterDTM , starting with version 2.0, 
provides an automatic mechanism to identify these 
water bodies, and associate to them the border (shore, 
strand, coastline) elevation. Water bodies are identified 
by means of a segmentation of the correlation image 
for correlation values less than the correlation 
threshold (default: 50 , on a scale from 0 [no 
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correlation] to 100 [identical]), and for band 3N pixels 
less than the image threshold (default: 30). Only 
segments with more than the minimum population 
limit (default: 1000) are considered water bodies. To 
change any of these parameters, click on “Change 
parameters” , click on the parameter to modify, and 
enter the new value. 

 Click on the “use water detection’  box to enable 
automatic detection, and click again to disable it. 

 
Use GCP’s: Click on the “Use GCP’s”  box if you want to enable 

the use of GCP’s currently defined for your Aster 
image. Please see “Using Ground Control Points”  for 
instructions how to define and import GCP’s. 

 
Extended correlation analysis: Use this option to enable the extended correlation 

mode. In the default processing, the last (decisive) 
processing step is being executed on a relative small 
image subset around the pixel being processed, with 
the approximate position of this subset (in other words, 
the approximate elevation value) being a result of the 
previous processing steps. If this approximation went 
wrong, the correlation analysis will fail for this 
particular pixel, even though eventually the overall 
conditions for a correlation analysis would be o.k.  In 
the extended correlation analysis mode, all pixels with 
correlation values less then 70 are being processed 
once again with a significantly larger image subset 
(extended range of possible elevations), eventually 
allowing to identify the correct elevation in another 
elevation range. However, the use of this option may 
increase significantly the processing time, and 
eventually lead to a larger number of false matches 
(due to the extended elevation range). 
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Use external DEM: Click the “Use external DEM” box to use an external 

DEM, either for assisting the elevation extraction, or to 
orthocorrect the ASTER bands by means of this DEM. 
In case there is not yet an external DEM defined, a 
selection dialog will pop up to interactively query the 
ENVI vector file. Click again to turn off the use of an 
external DEM. 

 
 
Select external DEM:  Opens the standard ENVI file selection dialog for 

opening an ENVI file which is to be used as external 
DEM. Upon importing the file, the area of overlap is 
determined and an error message is submitted in case 
there is no overlap between the external DEM and the 
VNIR 1A->1B file. 

 
 The external DEM file may be in geographic lat/lon or 

in any map projection ENVI supports; the units 
(elevation) are considered to be in meters (please 
convert units before importing the file if necessary). 
GTOPO30 files can be opened directly without prior 
conversion, clicking on the .dem file. SRTM .hgt files 
are also supported directly. 

 
 Once an external DEM has been imported successfully, 

the “Use external DEM” option is checked, and the 
external DEM will be used in the Aster DEM 
extraction, unless you uncheck the “Use external 
DEM” box. Using an external DEM has essentially two 
effects on the resulting DTM: 
1.) Each pixel of the external DEM is being used as an 

elevation tie point (fixed at the center coordinate). 
2.) AsterDTM uses highly reliable elevations derived 

at these tie point locations to compared to the tie 
point Z values, and to derive a mean offset which 
in turns converts the relative DTM into an absolute 
one. The derived offset can be checked through the 
Process Parameter Options window (Internal DEM 
tag). 

     
 
External DEM Nodata value: The numerical value for regions in the external DEM 

where no elevation is defined. 
 
Replace by external DEM where This Option allows the replacement of “bad”  (low 
Correlation < limit: correlation) DTM values by elevation values from the 

external DEM (where available) . 
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Use vector layer: Click the “Use vector layer”  box if you want to use  a 

user-defined vector layer to delimit areas where no 
elevation extraction should be carried out (please see 
“Select .evf file”  for details). Click again to turn off the 
use of a vector layer. 

  
 Observation: The option of using a vector file for 

delimiting water bodies has been maintained mainly 
for backwards compatibility, and should in almost all 
cases be obsolete due to the new automatic water 
detection. 

 
 
Select .evf file:  Opens the standard ENVI file selection dialog for 

opening an ENVI .evf vector file. The use of a vector 
file is indicated whenever there are medium size or 
large areas of water (lakes, sea, ocean), which in 
general produce unreliable results in the correlation 
process.  In case the “Use vector layer”  box is checked, 
AsterDTM takes the following actions on the vector 
file: 

o A mask is created from the .evf vector polygons. 
o Masked pixels are ignored during the DTM extraction 

process 
o After finishing the DTM extraction process, for each 

individual polygon, the average elevation for the 
border pixel for this polygon is derived, and associated 
to all pixels within the polygon.  

 
Observation 1: The vector file has to be of the type 
“polygon” , e.g. the result of the vectorization of a 
classification result. 
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Reset: Resets all processing parameters to the initial values. 
 
Accept: Saves changes to the settings, and closes the 

Processing Parameters Definition window. 
 
Cancel:  Closes the Processing Parameters Definition window 

without saving any changes to processing parameters. 
 
 
 
 
Options menu: About AsterDTM    
 
This option displays AsterDTM version information 
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3. AsterDTM batch job operation 
 
 
AsterDTM allows you extract DTM’s in a non-interactive way, thus permitting the processing 
of a large number of ASTER image in batch. The command structure is very similar to ENVI’s 
programming routines, with one command and a couple of keywords to define the processing 
parameters. 
 
 
ASTERDTM_DOIT 
 
Calling sequence: 
 
 
 ASTERDTM_DOIT 
 
Keywords: 
 
  
 CORR_FID (optional) 
 

Use this keyword to specify a named variable that will contain the file ID for the 
resulting output cross correlation file. This file ID can be used to access the processed 
data programmatically for subsequent processing 

 
 CORR_MATRIX_SIZE (optional) 
 

Use this keyword to specify the size of the image array used for correlation analysis. 
Valid values are 1 (3 x 3 matrix), 2 (5 x 5 matrix), 3 (7 x 7 matrix), 4 (9 x 9 matrix), 5 
(11 x 11 matrix), and 6 (13 x 13 matrix). Default is a 9 x 9 matrix size 
(CORR_MATRIX_SIZE = 4) . 

 
DIMS 

 
Use this keyword to specify the spatial subset to be used for the DTM extraction and 
orthocorrection. DIMS is a five-element array of long integers with the following 
definitions (identical to the ones used in ENVI programming routines: 
 

• DIMS(0): Unused for this function, set to -1. 
• DIMS(1): The starting X pixel. (The first pixel is number zero.) 
• DIMS(2): The ending X pixel. 
• DIMS(3): The starting Y pixel. (The first pixel is number zero.) 
• DIMS(4): The ending Y pixel.  

  
In case the dimensions defined by DIMS exceed the dimensions of the input ASTER 
image, then the ASTER input image dimensions are used instead. If the ASTER image 
is a level 1A image, then DIMS is being applied to the 1A->1B corrected file, not to the 
raw 1A file. 
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 DIRECTORY 
 

Use this keyword to specify a directory path, to process all ASTER 1A and/or 1B HDF 
files contained in this directory, or recursively in this directory and all subdirectories. 
AsterDTM will automatically identify all valid ASTER 1A and 1B in this directory, and 
derive the output filenames from the input ASTER file name, f.i : 
 

OUT_DEMNAME  =  input file name + “_DEM” 
OUT_DEMNAME  =  input file name + “_DEM” 
OUT_CORRNAME =  input file name + “_CORR” 
OUT_1Ato1BNAME  =  input file name + “_1Ato1B”  
OUT_ORTHONAME =  input file name + “_ORTHO” 
 

If you use the keyword DIRECTORY then the keywords FNAME will be ignored. 
Keywords OUT_CORRNAME, OUT_1BNAME, OUT_ORTHONAME,  
OUT_ORTHO_SWIRNAME and OUT_ORTHO_TIRNAME should be set (for 
instance to an empty string) in order to request the generation of the respective output 
file.  If the DIMS,  DTM_PIXSIZE or DTM_NODATA keywords are set, then these 
settings will be applied to all ASTER input files. 
 
Specify the complete directory path to search for ASTER 1A and 1B files in this 
directory only; add the “* ”  symbol to extend search to the whole subdirectory tree, 
starting from DIRECTORY  (see examples below).  
 

 
  
 DTM_FID (optional) 
 

Use this keyword to specify a named variable that will contain the file ID for the 
resulting output DTM file. This file ID can be used to access the processed data 
programmatically for subsequent processing 

 
 
 DTM_PIXSIZE_TYPE (optional) 
 

Use this keyword to define the output pixel size for the extracted DTM. Valid values are 
0 , 1 and 2  resulting in pixels sizes of 60 m, 30 m and 15 m respectively. The output 
correlation matrix will have the same pixel size as the DTM. 
Default pixel size type  is 1  ( 30 meters ). 

 
 DTM_NODATA_VALUE (optional) 
 

Use this keyword to define the data value assigned to pixels where no elevation value 
could be extracted. Valid values are integer. 
Default nodata value is   –9999  . 

 
 EXTENDED (optional) 
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Use this keyword to select the extended correlation analysis mode. In this mode, the 
number of internal tie points for the first three steps in the correlation analysis is 
doubled, and in the final step low correlation results are reprocessed with a larger 
elevation range  in order to account for steep slopes in the terrain. The extended mode 
can take significantly more time to process, especially in the presence of large areas of 
low correlation (f.i. water, snow fields, sand dunes etc.)  

 
 
EXT_DTMNAME (optional) 

 
Use this keyword to define the input file name for an external digital elevation file to be 
used in the extraction process (f.i. GTOPO30, SRTM data etc.). For any input ASTER 
file specified either through the FNAME keyword or through the DIRECTORY 
keyword, AsterDTM will check for any overlapping areas and apply the external DTM 
when possible, according to the rules and conditions described in “Options Menu -> 
select external DEM”. 
 
  

 FNAME  
 

Use this keyword to define the input ASTER 1A or 1B file name. The file has to be in  
the  HDF  format (HDF version 4.0). 
 
This keyword is being ignored when the DIRECTORY keyword is present.  

  
 NORTH_ORIENTED (optional) 
 

Use this keyword to have all output images (DTM, correlation image, orthocorrected 
bands)  be rotated to north orientation prior to being output to disk. This allows f.i. for 
automatic mosaicing of DTM output results from several ASTER images, which is not 
possible with the default orbit oriented output files. The default value for this keyword 
is NORTH_ORIENTED=0  (output files orbit oriented). 
 

  
O1Ato1B_FID (optional) 

 
Use this keyword to specify a named variable that will contain the file ID for the 
resulting output corrected 1A->1B file. This file ID can be used to access the processed 
data programmatically for subsequent processing.  
 
The keyword is being ignored if the input ASTER file is not level 1A . 

  
 ORTHO_FID (optional) 
 

Use this keyword to specify a named variable that will contain the file ID for the 
resulting output orthocorrected   file. This file ID can be used to access the processed 
data programmatically for subsequent processing.  
 
The keyword is being ignored if the keyword OUT_ORTHONAME is undefined . 
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OUT_DTMNAME 
 

Use this keyword to define the output file name for the resulting digital elevation 
model.   
 
If using the DIRECTORY option, this keyword is not needed (extracted DEMs 
are saved to output file names automatically derived from the ASTER input file 
names.) 
 
OUT_CORRNAME (optional) 

 
Use this keyword to define the output file name for the resulting cross 
correlations array.   
 
If using the DIRECTORY option, setting this keyword (to any value) will 
output the correlation file to an output file name automatically derived from the 
ASTER input file name.  
 
OUT_1Ato1BNAME (optional) 

 
Use this keyword to define the output file name for the resulting 1A->1B 
corrected image. If this keyword is undefined and the input ASTER image is 
level 1A then a temporary 1A->1B file is created, and deleted after processing is 
completed. 
 
If using the DIRECTORY option, setting this keyword (to any value) will 
output the 1A->1B file to an output file name automatically derived from the 
ASTER input file name.  
 
OUT_ORTHONAME (optional) 

 
Use this keyword to define the output file name for the resulting orthocorrected 
VNIR file. The orthocorrection is applied to the VNIR bands 1,2 and 3N in the 
case of a level 1B image, and to the 1A->1B corrected image in the case of a 
level 1A input image. If this keyword is undefined then  orthocorrection is not 
executed. 
 
If using the DIRECTORY option, setting this keyword (to any value) will 
output the VNIR orthocorrection result to an output file name automatically 
derived from the ASTER input file name.  
 
OUT_ORTHO_SWIRNAME (optional) 

 
Use this keyword to define the output file name for the resulting orthocorrected 
SWIR file. The orthocorrection is applied to the original SWIR bands in the case 
of a level 1B image, and to the 1A->1B corrected SWIR bands in the case of a 
level 1A input image (please mind the RADIANCE keyword to define whether 
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the output pixel values are converted to radiance, or not). If this keyword is 
undefined then  orthocorrection is not executed. 
 
If using the DIRECTORY option, setting this keyword (to any value) will 
output the SWIR orthocorrection result to an output file name automatically 
derived from the ASTER input file name.  
 
OUT_ORTHO_TIRNAME (optional) 

 
Use this keyword to define the output file name for the resulting orthocorrected 
TIR file. The orthocorrection is applied to the original TIR bands in the case of a 
level 1B image, and to the 1A->1B corrected TIR bands in the case of a level 1A 
input image (please mind the RADIANCE keyword to define whether the output 
pixel values are converted to radiance, or not). If this keyword is undefined then  
orthocorrection is not executed. 
 
If using the DIRECTORY option, setting this keyword (to any value) will 
output the TIR orthocorrection result to an output file name automatically 
derived from the ASTER input file name.  
 
RADIANCE  (optional) 

 
Use this keyword to have the orthocorrected output pixel values be converted to 
radiance, by means of the calibration parameters provided in the ASTER HDF 
file. When set (RADIANCE=1), this keyword applies to all orthocorrected 
output results.  The default value is RADIANCE=0 . 
 
WATER_FLAG  (optional) 

 
Use this keyword to define the automatic processing of water bodies. When set, 
(WATER_FLAG = 1) then the resulting correlation image is segmented, and 
low correlation areas which  fulfill the criteria imposed by the 
WATER_MINPOPULATION, WATER_MAXCORRVAL and 
WATER_MAXIMGVAL keywords are set to the border elevation in the 
resulting DTM output image. The default value for  WATER_FLAG is zero 
(automatic processing disabled). 
 
WATER_MINPOPULATION  (optional) 

 
Use this keyword to define the minimum area necessary in the segmented 
correlation image to constitute a water body. The WATER_FLAG keyword has 
to be set, in order for this keyword to take effect. The default value for 
WATER_MINPOPULATION is 1000  [pixels in the VNIR 3N band], 
corresponding to 15,000.00 m2 .  
 
WATER_MAXCORRVAL  (optional) 
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Use this keyword to define the maximum threshold in the correlation image to 
constitute a water body. Only correlation values less then or equal to this 
threshold are used in the subsequent segmentation process (water, due to it’s 
uniformity, gives in general a very low correlation signal). The WATER_FLAG 
keyword has to be set, in order for this keyword to take effect. The default value 
for WATER_MAXCORRVAL is   50 (possible values range from 1 to 100). 
 
WATER_MAXIMGVAL  (optional) 

 
Use this keyword to define the maximum threshold in band 3N (VNIR) of the 
input ASTER image to constitute a water body. Only pixels with DN’s less then 
or equal to this threshold are used in the subsequent water body detection 
process. The WATER_FLAG keyword has to be set, in order for this keyword to 
take effect. The default value for WATER_MAXIMGVAL is   40 (possible 
values range from 0 to 255). 
 

EXAMPLE: 
 
 This examples defines several calls to AsterDTM_doit (please change 

Directory separator to ‘ /’  for unix systems)  : 
 
    pr o exampl e_ast er dt m_doi t  
 
  ;  pr ocess al l  ast er  1a and/ or  1B i mages i n di r ect or y  d: \ dat a 
  ;  set  nodat a val ue t o –999,  and out put  pi xel s s i ze t o 60 m 
 
  ast er dt m_doi t , di r ect or y = ” d: \ dat a” , dt m_pi xsi ze_t ype = 0, $ 
   dt m_nodat a_val ue = - 999 
 

 
 
 
;  pr ocess al l  ast er  1a and/ or  1B i mages i n di r ect or y   
;  e: \ ast er dat a and r ecur si vel y i n al l  subdi r ect or i es,  and  
;  pr oduce t he out put  DEM and cor r el at i on f i l es  

   
  ast er dt m_doi t , di r ect or y = ” e: \ ast er dat a\ * ”  ,  out _cor r name=”  “  
 
   
 
 

;  ext r act  DTM f or  ASTER f i l e MyAst er Fi l e f or  a 700* 800 spat i al  
  ;  subset ,  and pr ovi de t he f i l e i d’ s f or  t he ext r at ed DTM and t he 
  ;  cor r el at i on mat r i x f or  f ur t her  pr ocessi ng 
 
 
  di ms = l ong( [ - 1, 1300, 1999, 2000, 2799] )   
 
  ast er dt m_doi t , f name = Ast er Name,  di ms = di ms, $ 
   out _dt mname = ” dt m_out put ” , out _cor r name = ” cor r _out put ” , $ 
   dt m_f i d = dt m_f i d,  cor r _f i d = cor r _f i d 
 
   

  end 
 

 
 
 
 


